Backup failing with key already exists exception on OneDrive

OK. I guess there is no short-term fix then. We need to rewrite the backed to use the new MS API.

Uninstalled Duplicati, Reinstalled, replaced DLL and imported Backupset - works now, really slow but it works. Thank You!

is it correct to assume that this new API will also be applicable for OD4B? And that the issues at OD4B should also be resolved when the new API will be in place?

So what is the current status?
I am patiently waiting for a bugfix

Hello, I am new to the forum because I am searching for a way to make the backup to OneDrive work again, because I like the way Duplicati works to easily backup all the family files. Currently I am running Duplicati on a Windows Server 2012 R2 with the offsite backup directed to OneDrive at a file count of 16565 Duplicati-files in the OneDrive online folder at a size of around 350 GB. Since I encountered the same problem I replaced the .dll. Afterwards OneDrive completely diappeared from the list of backup destinations. Thus I completely uninstalled Duplicati, rebooted, reinstalled it, rebooted, exchanged the .dll, rebooted, started Duplicati; but the problem still persists. Deleting all the backup jobs, doing the procedure of uninstalling, rebooting, … again, and then reimporting the backup jobs also didn’t change anything. I am running the latest experimental build now (Duplicati -, but I also tried it with the beta build. Both didn’t work.

What could I be doing wrong? What could I try to do?

Thanks for any help and any suggestions.

Kind regards from Germany,

Hi… I’ve tested the dll in linux, with the beta version, but I think it must work in all the systems.
Have you downloaded the correct file? You must click in the link (don’t save it), it will open Github site, then click in “View Raw” to download. If you save the file directly from this page it downloads the github page with the dll name, but not the real dll.

1 Like

Hello, thanks for your answer. I did all that and downloaded directly from Github including clicking View Raw. Could it be something OS-specific? When I copy the dll into Duplicati’s folder Windows asks me for permission to overwrite the existing dll and after granting the permission the dll in the folder has the new date and time. Do I have to do anything to make Duplicati “realize” that there is a new dll?

I just had a look at the dll files and I noticed that all of the other Backend-dlls are digitally signed and this one isn’t. Could this cause the problem that Duplicati does not seem to use the dll? Can I do anything about it like switching off the check for the digital signature?

Sorry, I don’t have Duplicati running in windows. Maybe @kenkendk can confirm if the signature is necessary on windows.

Hello, I tried to use osmogar’s workaround-dll and it does not work on my Windows Server 2012 R2 setup. I guess it might be the case because all the other backend-dlls are signed and this one isn’t. Could that be the problem because Duplicati just doen’t show OneDrive in the list of storage destinations anymore when I use this changed dll. Can I switch off the test for the digital signature within Duplicati or do anything else to make the backup to OneDrive work again?
Thanks in advance for any help. I would really like to be able to use Duplicati again because until now it was a great help in backing up all our family data.

I’ve tried the dll in a windows installation, and it makes the storage type selection appear blank. I think the problem is the signature too: a signed app can’t load unsigned dlls. I’ve tried to sign it with a self-signed certificate installed in the system and it don’t solve the issue.

@kenkendk: How about integrate the workaround in the master branch until the new api is used? so it will be in the next version. It should no cause problems in correct onedrive accounts.

Yes, that is fine by me. Do you want to make a pull request?

Done :slight_smile:


:fire: It is now merged into master :smiley:

Today my failing OneDrive account has started to work again. The list of files is consistent again and the time to backup has returned to normal. :clap:

Yay! Did you update to a specific version of Duplicati or did it just magically fix itself?

Just magic :rofl:
They (OneDrive) must have fixed the issue. I´m using now the last Canary with the patched dll. It was taking about 5-6 hours to complete the daily backup and today it took only 55 minutes. I´ve tested the list of files with the console application and there was no repeated entries.

Mine seems to have auto-magically fixed itself also :slight_smile:

Mine is also working correctly again. Great to see that.

A miracle. Mine is working again, too!