Backup errors, with filtered excluded folder

My backups always fail with one error, there is no error listed but there is a lot of warnings. Trying to get rid of the warnings I have set up filters to exclude folder but it doesn’t seam to work correctly. I’m using the latest Beta on osX, 10.13.5. I attach backup message and filter configuration here. So even if I have excluded folder I still get the error and I don’t understand why?

16

Hi @rocco, welcome to the forum!

It looks to me like the “Access to the path xxx is denied” error is probably related to OS permissions issues - are you running Duplicati as only the tray icon or as the service / daemon?

As just a test, can you try excluding the /Volumes/2tb/ folder and see if the error goes away? It’s possible Duplicati is trying to access the folder metadata BEFORE applying the folder filter.

Only as tray, didn’t know about the other daemon way.

This is not the only exclude that is problematic for me all the once that are excluded seams to create a permissions issue, well I’m trying to exclude them for that exact reason. Is there a way to see what is actually executed from the settings created in the UI?

If I’m understanding what you’re asking, you can use the job “Export …” menu and select “As Command-line”.

You could try running the tray-icon (or command line backup) with sudo or (su to root) and see if the errors go away…

Setting the ReadOnly option takes away the warnings, but then on the other hand my files are not backed up…

I’m not sure what you mean by “setting the ReadOnly option”. If you mean setting exclude to /Volumes/2tb/ then yes, that means you are no longer backing up the files. But this was just meant as a test, not a solution.

The “best” fix would likely be to run Duplicati as a service / daemon on your Mac as they usually have access to all files.

You might also try another test by running the tray-icon (or your exported “As Command-line”) FROM the command line using sudo or su root.

However, neither of those actually FIXES the problem that excludes don’t seem to be working correctly for you. Can you check the ownership and permissions of the .DocumentRevisions-V100 folder? (For the record, it looks like that folder is where MacOS stores the version histories of files for supported apps.)

@kenkendk, should something like the .DocumentRevisions-V100 folder be part of the OS specific excludes?

Setting readonly I was referening to the option: exclude-files-attributes: ReadOnly.

That removes the errors but readonly file will not get backup, even though I can read them.

Ah, that makes sense to me now. :slight_smile:

What are some of the folders other than .DocumentRevisions-V100 that you get the Access to the path xxx denied on?

Oh, and were you ale to test running Duplicati as root? (Just to confirm it is a permissions issue underlying the filter problem.)