Backing up to B2 fails as of 2021-04-01 with error SecureChannelFailure (The authentication or decryption has failed.)

I’ve been backing up some directories from a Debian server to B2, and everything worked just fine until April 1, 2021. As of that date, whenever Duplicati tries to connect to B2, it throws the error pasted in the subject line. The version of Mono is 4.6.2. Has there been a change of some kind that’s causing this? How do I fix it? Thanks.

See this thread:

Short answer: upgrade your version of Mono and restart Duplicati.

Thanks, that fixed it. Now, after running all my backups once, each one has the following warning in its log. Obviously the filenames are unique for each one, but is this a serious problem or something not to worry about?

2021-04-21 19:53:38 -04 - [Warning-Duplicati.Library.Main.Operation.Backup.UploadSyntheticFilelist-MissingTemporaryFilelist]: Expected there to be a temporary fileset for synthetic filelist (724,, but none was found?


Temporary filelists are expected to still be present when the previous backup was interrupted, but if not present it’s not a major problem. I am guessing subsequent backups did not throw that error, correct?

Correct, after that one time, the next time the backups ran they didn’t include that warning. Thanks.