Backblaze B2 401 Unauthorized


I am getting 401 Unauthorized errors to Backblaze B2. I have tried deleting and re-creating the bucket application key, but still get the 401. This connection has worked fine until about June 13th, which is the last recorded log in the Duplicati interface. Even now if I run the backup, I don’t see any new logs showing up in the interface.

The error I’m receiving is

System.Exception: 401 - unauthorized:
at Duplicati.Library.Backend.Backblaze.B2AuthHelper.AttemptParseAndThrowException (System.Exception ex) [0x000b5] in <7e654a6920954d59b0bcb60978e0d789>:0
at Duplicati.Library.Backend.Backblaze.B2AuthHelper.ParseException (System.Exception ex) [0x00000] in <7e654a6920954d59b0bcb60978e0d789>:0
at Duplicati.Library.JSONWebHelper.GetResponse (Duplicati.Library.Utility.AsyncHttpRequest req, System.Object requestdata) [0x000c6] in <21c487eee9024ff385348c90ce2d4189>:0
at Duplicati.Library.JSONWebHelper.ReadJSONResponse[T] (Duplicati.Library.Utility.AsyncHttpRequest req, System.Object requestdata) [0x00000] in <21c487eee9024ff385348c90ce2d4189>:0
at Duplicati.Library.JSONWebHelper.GetJSONData[T] (System.String url, System.Action1[T] setup, System.Action1[T] setupbodyreq) [0x00024] in <21c487eee9024ff385348c90ce2d4189>:0
at Duplicati.Library.JSONWebHelper.PostAndGetJSONData[T] (System.String url, System.Object item, System.String method) [0x00023] in <21c487eee9024ff385348c90ce2d4189>:0
at Duplicati.Library.Backend.Backblaze.B2.get_Bucket () [0x00039] in <7e654a6920954d59b0bcb60978e0d789>:0
at Duplicati.Library.Backend.Backblaze.B2.List () [0x00031] in <7e654a6920954d59b0bcb60978e0d789>:0
at Duplicati.Library.Interface.BackendExtensions.TestList (Duplicati.Library.Interface.IBackend backend) [0x00000] in :0
at Duplicati.Library.Backend.Backblaze.B2.Test () [0x00000] in <7e654a6920954d59b0bcb60978e0d789>:0
at Duplicati.Server.WebServer.RESTMethods.RemoteOperation.TestConnection (System.String url, Duplicati.Server.WebServer.RESTMethods.RequestInfo info) [0x000b7] in :0
at Duplicati.Server.WebServer.RESTMethods.RemoteOperation.POST (System.String key, Duplicati.Server.WebServer.RESTMethods.RequestInfo info) [0x00091] in :0
at Duplicati.Server.WebServer.RESTHandler.DoProcess (Duplicati.Server.WebServer.RESTMethods.RequestInfo info, System.String method, System.String module, System.String key) [0x00280] in :0

Any ideas?

Exact same problem as of today

Api change from backblaze?

I’m seeing this as well.

They’ve acknowledged it:

It is only Duplicati for me. I’m using CloudSync on my Synology NAS that syncs data to B2 buckets and it is working fine.

Jumped from Amazon Cloud Drive to B2… two days later… B2 breaks. Great.

It’s working again for me.

Yup they fixed it.