B2 error when verifying or downloading

I have a backup running to B2. I think it had been working OK but I’m now getting errors when verifying or trying to download files. The error is “Unable to connect to remote server”.

Test connection works fine, and it still seems to be uploading with no problems. I can logon on to B2 separately and it all looks fine, and can download files from the B2 site OK.

Any ideas what the problem could be.



is one issue which maybe fits here, although the symptoms are different. Short of that, may take debug.
Overview and other pages explain how B2 uses a lot of different URLs, none of which are the web login.

Thanks. I had already seen that topic, and changed my router DNS to but it is still not working. Maybe I just need to give it more time.

The error message I can find from the live log is this, is that what you mean by the debug? Does it help:

{"ClassName":"System.Net.WebException","Message":"Unable to connect to the remote server","Data":null,"InnerException":{"NativeErrorCode":10013,"ClassName":"System.Net.Sockets.SocketException","Message":"An attempt was made to access a socket in a way forbidden by its access permissions","Data":null,"InnerException":null,"HelpURL":null,"StackTraceString":" at System.Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)\r\n at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)\r\n at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)","RemoteStackTraceString":null,"RemoteStackIndex":0,"ExceptionMethod":"8\nInternalEndConnect\nSystem, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089\nSystem.Net.Sockets.Socket\nVoid InternalEndConnect(System.IAsyncResult)","HResult":-2147467259,"Source":"System","WatsonBuckets":null},"HelpURL":null,"StackTraceString":" at Duplicati.Library.Main.AsyncDownloader.AsyncDownloaderEnumerator.AsyncDownloadedFile.get_TempFile()\r\n at Duplicati.Library.Main.Operation.TestHandler.DoRun(Int64 samples, LocalTestDatabase db, BackendManager backend)","RemoteStackTraceString":null,"RemoteStackIndex":0,"ExceptionMethod":"8\nget_TempFile\nDuplicati.Library.Main, Version=, Culture=neutral, PublicKeyToken=null\nDuplicati.Library.Main.AsyncDownloader+AsyncDownloaderEnumerator+AsyncDownloadedFile\nDuplicati.Library.Utility.TempFile get_TempFile()","HResult":-2146233079,"Source":"Duplicati.Library.Main","WatsonBuckets":null}


Mainly it looks like the “Unable to connect to the remote server” confirms what was already suspected. A socket would likely be trying to connect to a B2 server as part of the “AsyncDownloader” within Duplicati.

There’s not really any ordinary logging in this area. There are a couple of ways you could try to watch the activity. What OS is this? On Windows, if you run Duplicati as you at login (not as a Windows service), a
netstat -ano | findstr SYN gets addresses the system is trying to connect to. You can check it was Duplicati by checking in Task Manager to see which process has the PID on the right end of netstat lines.

Sysinternals Process Explorer can let you watch only Duplicati, using right-click Properties, then TCP/IP.

If you can get an IP address either way, then we can attempt to see whether it seems like it should be up.

One thing that this may miss is if the address is answering but the server is quickly rejecting the connect.
You could try catching/inspecting those on a quiet system (no open browser) with Wireshark or similar…

Attempting to research your message didn’t immediately come to good explanations at a relevant level…

Yes, it is Windows 10, and I run Duplicati as myself, not a service. I’ll follow your instructions and see what I can come up with.

I used process explorer and found the addresses that were being used. Then noticed that the Mcafee firewall was blocking one of them :roll_eyes:

After unblocking it now works. A week or 2 ago it was working fine, so no idea why they decided to start blocking it.

Thanks for you help. Pointing me to look at the addresses was what was needed.

1 Like