Amazon S3 destination

I have a problem with backups on an Amazon S3 compatible destination (Qnap NAS).
If I back up on WebDav or FTP everything is OK, if I back up S3 I get this error:
Errors: [Failed to process file => The file was downloaded and had size 565137 but the size was expected to be 52418102]
On the backend the size is 52418102, is it a bug?
I also noticed that even by indicating the Amazon S3 Compatible storage type, after saving the configuration the storage type becomes Amazon S3.

The miss match is likely because the local database recorded a different size for some reason. A repair or a recreate of the local database should resolve this.
It should be noted that it can be an issue with the backend. If the size has actually changed you may potentially have lost data.

The S3 Compatible vs Amazon S3 setting does not matter. They’re the same in the backend but are shown in two places in the frontend to make it more user friendly :slight_smile:

Thanks Pectojin,
I had already tried to delete and recreate the database without success, I also tried with different backup sets, but the error remains.
Could it be an error related to the QNAP (even if I have also updated the firmware)?

Hmm, I’m not sure.

Did you copy the backup data over to the S3 storage or did Duplicati start from fresh?

All started from fresh

That sounds like some kind of bug in either Duplicati or in the S3 compatible backend. Can you restore your data from the backend?

It’s especially strange because the expected size is equal to the size you’re seeing in the backend. So somehow Duplicati is receiving something in a different size when downloading the file.

So nobody uses Qnap S3 as a backend?