Always on pause after hibernation

Hello,

I use the current beta build to run two daily backups (one local and one to OneDrive). They are both set to run every evening. Therefore the computer automatically resumes from hibernation using a time-based wake-up program called Lights-Out. Five minutes after resuming the first backup is scheduled to start. Unfortunately Duplicati always goes to pause-mode and I manually have to click on continue so that the backups really start. When I start them manually or if the computer had not been in hibernation since the last user action in Duplicati or since the last backup, everything works as it should. I also used the setting for the pause after restart or hibernation in Duplicati and it did not help.
What could I do so that my backups start as scheduled?

Thanks for any help in advance.

Have you checked this setting (under settings)?

grafik

Edit: Sorry, i missed that you already set this. I had the same issue (after machine restart) and just not looked at this setting.

Edit 2: Did you try to set this at lowest possible timeframe (1 sec)?

If you’re running as a service on Windows, you might want to make sure the service isn’t set for delayed start.

Hello again,

thanks for the advice. I set the “Pause after startup or hibernation”-option to 1 sec but it did not help. I am also not running Duplicati as a service.
This evening the backup also did not start and Duplicati is on pause. But the strange thing is that if I have a look at the Windows Task Manager Duplicati.GUI.TrayIcon consumes changing percentages of CPU-power always ranging somewhere at around 50%.
How can that be if it is on pause? And do you have any other suggestions what I could do to make Duplicati run correctly according to the schedule?
Would it be an option to cancel the builtin Duplicati schedule, export the command line to a batch file and make that run at the desired time using the Windows scheduler? Would I then still be able to see the results of the backup using the GUI?

Thanks in advance for any help.

Hmmm, let’s start with this - how do you know that Duplicati is in “pause mode”?

The taskbar icon is grey and shows the pause sign and in the browser-GUI a start sign and the possibility to continue are offered. Furthermore the logs show that the backup jobs had not been run. And finally, when I click the start sign I don’t have to click on run now for each job but they start running immediately as if there had been missed backup times (e.g. like when the computer had not been switched on at all).

I didn’t have these pronlems before when I used the same configuration of Duplicati settings on my Windows Server 2012 R2 installation. But then I started from scratch on the machine and installed Windows 10. Since this change the behaviour is as described.

Thanks for confirming that. I wanted to make sure you weren’t confused, as some users have been, by the “pause” icon in the web GUI used to actually pause the already running server.

I still don’t know what would be causing this so we’re still in the “gather more info” stage… Does the same thing happen after a power on or only after wake from hibernation?

Oh, and when it happens, what do you see in the estimatedPauseEnd, programState, and pauseTimeRemain rows in the “Server state properties” at the bottom of the About -> “System Info” page?

Server state properties
lastEventId : 44
lastDataUpdateId : 2
lastNotificationUpdateId : 0
estimatedPauseEnd : 0001-01-01T00:00:00
activeTask :
programState : Running
lastErrorMessage :
connectionState : connected
xsfrerror : false
connectionAttemptTimer : 0
failedConnectionAttempts : 0
lastPgEvent :
updaterState : Waiting
updatedVersion : 2.0.2.19_canary_2018-02-12
updateReady : false
updateDownloadProgress : 0
proposedSchedule : []
schedulerQueueIds : []
pauseTimeRemain : 0

Sure - while I haven’t personally tried it I believe some users have gone that route to better handle automatic backups when a USB drive is attached.

As far as viewing results, again I haven’t tried this myself but I think that as long as you have the --dbpath parm correct then you should be ale to see historical info about the backup. However, I think the GUI won’t show the state of the currently running job (except maybe in the “Server state properties” section…though I could be wrong.

1 Like

Hi,

thanks for your attempt to help. Today the PC woke up as planned but 10 minutes later Duplicati is still on pause although I did not set any pause time in the settings. This is the status page:

lastEventId : 109
lastDataUpdateId : 6
lastNotificationUpdateId : 0
estimatedPauseEnd : 0001-01-01T00:00:00
activeTask :
programState : Paused
lastErrorMessage :
connectionState : connected
xsfrerror : false
connectionAttemptTimer : 0
failedConnectionAttempts : 0
lastPgEvent :
updaterState : Waiting
updatedVersion :
updateReady : false
updateDownloadProgress : 0
proposedSchedule : [{"Item1":"2","Item2":"2018-02-23T20:05:00Z"},{"Item1":"1","Item2":"2018-02-23T20:10:00Z"}]
schedulerQueueIds : []
pauseTimeRemain : 0

Can you see (or guess) what is going wrong?

Posting the status page contents is useful (thanks!) but it doesn’t point to any specific that I can see.

It’s possible Duplicati has gone into pause mode BEFORE the hibernate occurs, but I don’t know how that would happen either…

While I can’t recall other users having this particular issue, perhaps @kenkendk or @kees-z might…

Oh, and I know it’s geared for Duplicati 1.3, but this page suggests using schedules in Lights-Out instead of the built-in Duplicati scheduler.

Thanks for the suggestions. I did not use the how-to from the Lights-Out blog because I seem to have found an easier solution for my use case.
Just in case anyone faces the same problem, for me it seems to work since I changed Duplicati to a service-installation and set Lights-Out to always stop the service when hibernating and start the service again when resuming. Finally, it is working.
I hope it will keep working because I really like the way Duplicati works and I appreciate all the great work done by the Duplicati team.

1 Like

So we still don’t know why the (tray icon?) was on pause after hibernating, but in glad to hear you found a solution that works for you!

Hopefully Lights Out will add a Duplicati 2 page soon and maybe use your method. :smiley: