2018 Google Drive can't restore [solved]

I am trying to look back at an older archive, vintage 2018, that is on google drive. I imported a json file to restore the configuration. I recreated the database several times because it’s not clear it’s working. The status bar at top says “Recreating database…”; that goes on for a while. It throws several OAuth errors (see below). When it’s done and I try to restore there is no information about what files are in the archive.

I have been through the OAuth procedure several times and Test Connection works.

Failed to connect: Failed to authorize using the OAuth service: Server error. If the problem persists, try generating a new authid token from: Duplicati OAuth Handler

After the trying the stuff below, I tried to get Duplicati to use the database that (I thought) got generated in step 2) below. Duplicati didn’t like that and threw a bunch of errors. Then I deleted the database again and repaired again and it worked.

Additional data points:

  1. Another config file of the same vintage worked fine.
  2. I was able to successfully Recreate Database by doing a restore directly from the destination files.

I’d still like to Recreate Database in a config file so I can browse the archive at leisure.