0 remote files 0 were downloaded

Hi, I am new.
I am trying to restore a backUp, but Duplicati can not find files
I use

Duplicati.CommandLine.RecoveryTool.exe download “ftp://...:21/pools/A/A0/BackSisssa/DonWeb/Firma?auth-username=sistemas%5Cadministrador&auth-password=" C:\Salvame --passphrase="*****”

But the result is this:
Dowload complete , 0 remote files 0 were downloaded

I can see two big files with like this
" duplicati-b69a2a32a50bb4c6d8780389efdbf7442.dblock.zip.aes

What am i doing wrong?

Can you point it at the files another way? Seems whatever you’re doing that its either not actually at the correct path or some other issue resulting in a poorly worded error…

0 remote files, 0 downloaded seems like its not finding them with that line you have there.

Trying another way will (should?) at least give you an idea if you have it correct or not. If you can’t do anything else then you have to fiddle with it. I don’t use ftp:// so can’t check it out. Maybe someone else can.

For all I know its permission based. FTP, SSH, etc stuff like that can still be funny with other applications even with the same username and pass from permissions. I have FTP and SSH in development stuff I did and had to do a lot of weird error messages some due to shared user. I don’t know fully what you’re doing with your set up.

Can I ask why you are using this tool? Normally to restore (from command line) you should just use Duplicati.CommandLine.exe.

Thanks a lot for your response.
I have been attack by a virus, I need to recover my backUp.
I understand what you said about FTP. I have copy the files
To my machine, I have it in c:\backUp
Can I recover the information from there?

Hi drwtsn32,
I am very new here.
I tryed this too

Duplicati.CommandLine.exe restoreftp://*//pools/A/A0/BackSisssa/DonWeb/Firma?auth-username=sistemas%5Cadministrador&auth-password=&ftp-passive=true" C:\Salvame – passphrase="*"

But I said:
Listing remote folder …
Listing remote folder …
Listing remote folder …
Listing remote folder …
Listing remote folder …

System.Net.WebException: The remote server returned an error: (530) Not logged in.
at Duplicati.Library.Main.BackendManager.List()
at Duplicati.Library.Main.Operation.RecreateDatabaseHandler.DoRun(LocalDatabase dbparent, Boolean updating, IFilter filter, NumberedFilterFilelistDelegate filelistfilter, BlockVolumePostProcessor blockprocessor)
at Duplicati.Library.Main.Operation.RestoreHandler.Run(String[] paths, IFilter filter)
at Duplicati.Library.Main.Controller.<>c__DisplayClass15_0.b__0(RestoreResults result)
at Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action1 method) at Duplicati.Library.Main.Controller.Restore(String[] paths, IFilter filter) at Duplicati.CommandLine.Commands.Restore(TextWriter outwriter, Action1 setup, List1 args, Dictionary2 options, IFilter filter)
at Duplicati.CommandLine.Program.ParseCommandLine(TextWriter outwriter, Action1 setup, Boolean& verboseErrors, String[] args) at Duplicati.CommandLine.Program.RunCommandLine(TextWriter outwriter, TextWriter errwriter, Action1 setup, String[] args)
‘auth-password’ is not recognized as an internal or external command,
operable program or batch file.
‘ftp-passive’ is not recognized as an internal or external command,
operable program or batch file.

Are you recovering to the original system after cleaning up the virus, or is this a different system?

Were original backups made by the GUI or Duplicati.CommandLine.exe? I’m noticing URL varies.
Your second one added &ftp-passive=true (and seemingly didn’t put the target URL in quotes).
Both URLs supply an empty password. Is that what FTP server needs? Maybe it’s why it rejected.

Restoring files from a backup
Restoring files if your Duplicati installation is lost
are the easiest ways to restore. The GUI will give you good lead-through and avoid quoting errors.
If you’ve always used command line, then use the same URL you used for backups, if you have it.

The URL is also available from GUI Export As Command-line if you used GUI and it’s still working.
But if it’s working or fixable, then might as well use it for restore rather than inventing CLI methods.

Any idea how much you backed up? The dblock files default to 50 MB, so two is a pretty tiny backup.
You should generally have a dindex file for each dblock, and one or more dlist files (one per version).

RecoveryTool will need dblock and dlist files. CommandLine will also need dindex. What do you have?
If you made backup files local, then Local folder or drive gives URL format. Simplest is just c:\backup

With the file on my machine I tryed
.\Duplicati.CommandLine.exe restore C:\test_bk_rec\

Now I have the error:
Found 61992 files at the remote storage, but none that could be parsed

Is thsi because I have 2 files like this:
duplicati-b69a2a32a50bb4c6d8780389efdbf7442.dblock.zip.aes ?

What’s in there? 61992 not-Duplicati-related files, or lots of Duplicati dblock, dindex, and dlist files?

or are you saying that you have ONLY 2 dblock files (how big?) and are missing other needed ones.
If you can’t find at least a dlist file and a dblock file, then you haven’t found (or fetched) your backup.

yes, the only I hace is the two dblock.
Is there any way of see the information?

Sure you can see the raw content, but what for? It’s just anonymous blocks from your source files.
If you really want to look, AES Crypt can decrypt, and Windows can unzip to show the raw blocks.
The only information listing file paths and how to reassemble is in a file with dlist in the filename.
It will also have the date in its file name. How the backup process works talks more about the files.
Keep looking for dlist files wherever the backup destination was. Did backup actually complete?

Sorry, I do not know If I backUp complete.
I mean If I can see my files , even If I have nothing else than the dblocks?

If you can’t find a dlist file, you can’t see your file names because they’re in the dlist, and you can’t see your file contents because all you have are a load of blocks without any data on what files they’re from.


It’s very odd that you have dblock files without dindex files, even if backup didn’t complete and do dlist.
Are you totally sure there are no others? And again, how big are those dblock files. Can they decrypt?
I wonder if you might have tried to set your Remote volume size or --dblock option absurdly large?
That could have tried to put each backup run in a dblock, and maybe it didn’t finish, which would mean dindex file didn’t upload, and you only have part of the dblock file (which means it won’t even decrypt).
Exact behavior depends on your upload speed and how your FTP server handles partly uploaded files.

Regardless, if you can’t find a dindex and dlist at backup destination, your backup never completed.

Incomplete incremental backups can be somewhat handled, but never-completed may be harder.

Either way, what can be done depends on what survived on your original backup system, e.g. its
Database which exists for both GUI and commandline. Did this virus destroy or lock all the files?

I’m still asking about the situation. If you can’t answer, that’s fine, but not much help can be given.